The 3rd party provider has implemented a fix, and the result seems promising. We will continue to monitor the situation.
Posted Jun 12, 2025 - 18:40 CEST
Identified
The issue is caused by a service disruption at a 3rd party vendor. They are working on resolving the issue.
We will post updates as soon as we have more information.
Posted Jun 12, 2025 - 17:32 CEST
Update
We are continuing to investigate the issue.
If you are using our Web application you can submit a support ticket using the Contact support form.
Posted Jun 12, 2025 - 17:05 CEST
Investigating
We are currently experiencing delay in e-mail delivery to support@admincontrol.com. Investigations are ongoing and we will update this incident as soon as we have more information.
We sincerely apologise for the inconvenience that this is causing. If your request is urgent please call us on +47 22 83 61 00.
Posted Jun 12, 2025 - 16:19 CEST
This incident affected: Services (Support systems).